Back to overview
Downtime

Electricity driven outage

Mar 8, 2026 at 9:08pm UTC
Affected services
lumanesence.co.uk

Resolved
Mar 9, 2026 at 7:36am UTC

This outage has been resolved and services have been restored!

Created
Mar 8, 2026 at 9:08pm UTC

My house's electric credit has plummeted into minus. To prevent running down this minus value my homelab has been shut down until tomorrow